use strict;
my $str = '<br id="foo" style="display:none">
<spam id="bar">sometext</span>
<br id="bun" />
<div class="foo">
<div class="bar">
<a href="baz.php">baz</a>
</div>
</div>';
my $regex = qr/(<)(br|div)([^>]+?)(\/?\s*>)/mip;
my $subst = '\\1\\2\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";