# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<)(br|div)([^>]+?)(\/?\s*>)"
test_str = ("<br id=\"foo\" style=\"display:none\">\n"
"<spam id=\"bar\">sometext</span>\n"
"<br id=\"bun\" />\n"
"<div class=\"foo\">\n"
" <div class=\"bar\">\n"
" <a href=\"baz.php\">baz</a>\n"
" </div>\n"
"</div>")
subst = "\\1\\2\\4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.