re = /(<)(br|div)([^>]+?)(\/?\s*>)/mi
str = '<br id="foo" style="display:none">
<spam id="bar">sometext</span>
<br id="bun" />
<div class="foo">
<div class="bar">
<a href="baz.php">baz</a>
</div>
</div>'
subst = '\\1\\2\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result