using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\(1054, ""Unknown column 'inf(e0)?' in 'field list'""\))
|
(ProgrammingError: inf can not be used with MySQL)";
string input = @"(1054, ""Unknown column 'infe0' in 'field list'"")
(1054, ""Unknown column 'inf' in 'field list'"")
ProgrammingError: inf can not be used with MySQL";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}