const regex = /(\(1054, "Unknown column 'inf(e0)?' in 'field list'"\))
|
(ProgrammingError: inf can not be used with MySQL)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\(1054, "Unknown column \'inf(e0)?\' in \'field list\'"\\))
|
(ProgrammingError: inf can not be used with MySQL)', 'gm')
const str = `(1054, "Unknown column 'infe0' in 'field list'")
(1054, "Unknown column 'inf' in 'field list'")
ProgrammingError: inf can not be used with MySQL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}