// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?xm)(\(1054, "Unknown column 'inf(e0)?' in 'field list'"\))
|
(ProgrammingError: inf can not be used with MySQL)"#).unwrap();
let string = "(1054, \"Unknown column 'infe0' in 'field list'\")
(1054, \"Unknown column 'inf' in 'field list'\")
ProgrammingError: inf can not be used with MySQL";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}