import re
regex = re.compile(r"""
(\(1054, "Unknown column 'inf(e0)?' in 'field list'"\))
|
(ProgrammingError: inf can not be used with MySQL)
""", flags=re.VERBOSE | re.MULTILINE)
test_str = ("(1054, \"Unknown column 'infe0' in 'field list'\")\n"
"(1054, \"Unknown column 'inf' in 'field list'\")\n"
"ProgrammingError: inf can not be used with MySQL")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")