import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\(1054, \"Unknown column 'inf(e0)?' in 'field list'\"\\))\n"
+ "|\n"
+ "(ProgrammingError: inf can not be used with MySQL)";
final String string = "(1054, \"Unknown column 'infe0' in 'field list'\")\n"
+ "(1054, \"Unknown column 'inf' in 'field list'\")\n"
+ "ProgrammingError: inf can not be used with MySQL";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}