# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?\]/[$2$4$6$8$10]/g;t' <<< "[bad column name]
[bad column]
[very very bad column name]
"