import Foundation
let pattern = #"\[((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[bad column name]
[bad column]
[very very bad column name]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[$2$4$6$8$10]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)