import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[((\\w+)\\s?)?((\\w+)\\s?)?((\\w+)\\s?)?((\\w+)\\s?)?((\\w+)\\s?)?\\]";
final String string = "[bad column name]\n\n"
+ "[bad column]\n\n"
+ "[very very bad column name]\n";
final String subst = "[$2$4$6$8$10]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}