#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?\]"
Local $sString = "[bad column name]" & @CRLF & _
"" & @CRLF & _
"[bad column]" & @CRLF & _
"" & @CRLF & _
"[very very bad column name]" & @CRLF & _
""
Local $sSubst = "[$2$4$6$8$10]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)