use strict;
my $str = '[bad column name]
[bad column]
[very very bad column name]
';
my $regex = qr/\[((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?\]/p;
my $subst = '[$2$4$6$8$10]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";