using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?\]";
string substitution = @"[$2$4$6$8$10]";
string input = @"[bad column name]
[bad column]
[very very bad column name]
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}