// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?\]").unwrap();
let string = "[bad column name]
[bad column]
[very very bad column name]
";
let substitution = "[$2$4$6$8$10]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}