const regex = /\[((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[((\\w+)\\s?)?((\\w+)\\s?)?((\\w+)\\s?)?((\\w+)\\s?)?((\\w+)\\s?)?\\]', 'g')
const str = `[bad column name]
[bad column]
[very very bad column name]
`;
const subst = `[$2$4$6$8$10]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);