package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?\]`)
var str = `[bad column name]
[bad column]
[very very bad column name]
`
var substitution = "[$2$4$6$8$10]"
fmt.Println(re.ReplaceAllString(str, substitution))
}