# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<head>\s*([\s\S]*?)\s*<\\/head>/$1/gmi;t' <<< "<html lang=\"en\">
<head>
<meta http-equiv ...............
...................
</head> ..............
...............
</html>"