using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<head>\s*([\s\S]*?)\s*<\/head>";
string substitution = @"$1";
string input = @"<html lang=""en"">
<head>
<meta http-equiv ...............
...................
</head> ..............
...............
</html>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}