re = /<head>\s*([\s\S]*?)\s*<\/head>/mi
str = '<html lang="en">
<head>
<meta http-equiv ...............
...................
</head> ..............
...............
</html>'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result