const regex = /<head>\s*([\s\S]*?)\s*<\/head>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<head>\\s*([\\s\\S]*?)\\s*<\\\/head>', 'gmi')
const str = `<html lang="en">
<head>
<meta http-equiv ...............
...................
</head> ..............
...............
</html>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);