import Foundation
let pattern = #"<head>\s*([\s\S]*?)\s*<\/head>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<html lang="en">
<head>
<meta http-equiv ...............
...................
</head> ..............
...............
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)