$re = '/<head>\s*([\s\S]*?)\s*<\/head>/mi';
$str = '<html lang="en">
<head>
<meta http-equiv ...............
...................
</head> ..............
...............
</html>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;