import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<head>\\s*([\\s\\S]*?)\\s*<\\/head>";
final String string = "<html lang=\"en\">\n"
+ "<head>\n"
+ " <meta http-equiv ...............\n"
+ " ...................\n"
+ "</head> ..............\n"
+ "...............\n"
+ "</html>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}