use strict;
my $str = '<html lang="en">
<head>
<meta http-equiv ...............
...................
</head> ..............
...............
</html>';
my $regex = qr/<head>\s*([\s\S]*?)\s*<\/head>/mip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";