const regex = /blog/([0-9]{4})/(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('blog\/([0-9]{4})\/(.*)', 'gm')
const str = `https://www.mcb-bank.com/business/products/business-customer-account-information`;
const subst = `/$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);