import re
regex = re.compile(r"blog/([0-9]{4})/(.*)", flags=re.MULTILINE)
test_str = "https://www.mcb-bank.com/business/products/business-customer-account-information"
subst = "/$1"
result = regex.sub(subst, test_str)
if result:
print(result)