use strict;
my $str = 'https://www.mcb-bank.com/business/products/business-customer-account-information';
my $regex = qr/blog/([0-9]{4})/(.*)/mp;
my $subst = '/$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";