// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)blog/([0-9]{4})/(.*)").unwrap();
let string = "https://www.mcb-bank.com/business/products/business-customer-account-information";
let substitution = "/$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}