# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{9}) (\d{5})/$1$2/gm;t' <<< "123456789 12345678
12345678 12345
123456789 123456
123456789 12345
123456789 AZERT"