use strict;
my $str = '123456789 12345678
12345678 12345
123456789 123456
123456789 12345
123456789 AZERT';
my $regex = qr/(\d{9}) (\d{5})/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";