const regex = /(\d{9}) (\d{5})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{9}) (\\d{5})', 'gm')
const str = `123456789 12345678
12345678 12345
123456789 123456
123456789 12345
123456789 AZERT`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);