// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{9}) (\d{5})").unwrap();
let string = "123456789 12345678
12345678 12345
123456789 123456
123456789 12345
123456789 AZERT";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}