import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{9}) (\\d{5})";
final String string = "123456789 12345678\n"
+ "12345678 12345\n"
+ "123456789 123456\n"
+ "123456789 12345\n"
+ "123456789 AZERT";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}