#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d{9}) (\d{5})"
Local $sString = "123456789 12345678" & @CRLF & _
"12345678 12345" & @CRLF & _
"123456789 123456" & @CRLF & _
"123456789 12345" & @CRLF & _
"123456789 AZERT"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)