re = /(\d{9}) (\d{5})/m
str = '123456789 12345678
12345678 12345
123456789 123456
123456789 12345
123456789 AZERT'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result