# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"\d+"//gm;t' <<< "{
\"1\" : 12,
\"2\" : 24,
\"3\" : 36,
\"4\" : 44,
\"5\" : 138,
\"6\" : 195,
\"7\" : 127,
\"8\" : 91,
\"9\" : 52,
\"10\" : 45,
\"11\" : 21,
\"12\" : 15
}"