$re = '/"\d+"/m';
$str = '{
"1" : 12,
"2" : 24,
"3" : 36,
"4" : 44,
"5" : 138,
"6" : 195,
"7" : 127,
"8" : 91,
"9" : 52,
"10" : 45,
"11" : 21,
"12" : 15
}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;