use strict;
my $str = '{
"1" : 12,
"2" : 24,
"3" : 36,
"4" : 44,
"5" : 138,
"6" : 195,
"7" : 127,
"8" : 91,
"9" : 52,
"10" : 45,
"11" : 21,
"12" : 15
}';
my $regex = qr/"\d+"/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";