const regex = /"\d+"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"\\d+"', 'gm')
const str = `{
"1" : 12,
"2" : 24,
"3" : 36,
"4" : 44,
"5" : 138,
"6" : 195,
"7" : 127,
"8" : 91,
"9" : 52,
"10" : 45,
"11" : 21,
"12" : 15
}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);