# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"\d+\""
test_str = ("{\n"
" \"1\" : 12,\n"
" \"2\" : 24,\n"
" \"3\" : 36,\n"
" \"4\" : 44,\n"
" \"5\" : 138,\n"
" \"6\" : 195,\n"
" \"7\" : 127,\n"
" \"8\" : 91,\n"
" \"9\" : 52,\n"
" \"10\" : 45,\n"
" \"11\" : 21,\n"
" \"12\" : 15\n"
" }")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.