import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"\\d+\"";
final String string = "{\n"
+ " \"1\" : 12,\n"
+ " \"2\" : 24,\n"
+ " \"3\" : 36,\n"
+ " \"4\" : 44,\n"
+ " \"5\" : 138,\n"
+ " \"6\" : 195,\n"
+ " \"7\" : 127,\n"
+ " \"8\" : 91,\n"
+ " \"9\" : 52,\n"
+ " \"10\" : 45,\n"
+ " \"11\" : 21,\n"
+ " \"12\" : 15\n"
+ " }";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}