# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\[|:|,)\s*)'((?:\\'|[^'])*?[^\\])?'(?=\s*(?:\]|}|,))/$1"$2"/g;t' <<< "{
aa:'a \'a ab',test:\"ab\",foo:\"bar\",
intervak:1,
array:['test',\"t\\"est\",'tet\'s'],
'test':\"test te't test\"
}"