$re = '/((?:\[|:|,)\s*)\'((?:\\\\\'|[^\'])*?[^\\\\])?\'(?=\s*(?:\]|}|,))/';
$str = '{
aa:\'a \\\'a ab\',test:"ab",foo:"bar",
intervak:1,
array:[\'test\',"t\\"est",\'tet\\\'s\'],
\'test\':"test te\'t test"
}';
$subst = "$1\"$2\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;