const regex = /((?:\[|:|,)\s*)'((?:\\'|[^'])*?[^\\])?'(?=\s*(?:\]|}|,))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\[|:|,)\\s*)\'((?:\\\\\'|[^\'])*?[^\\\\])?\'(?=\\s*(?:\\]|}|,))', 'g')
const str = `{
aa:'a \\'a ab',test:"ab",foo:"bar",
intervak:1,
array:['test',"t\\"est",'tet\\'s'],
'test':"test te't test"
}`;
const subst = `$1"$2"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);