#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?:\[|:|,)\s*)'((?:\\'|[^'])*?[^\\])?'(?=\s*(?:\]|}|,))"
Local $sString = "{" & @CRLF & _
" aa:'a \'a ab',test:"ab",foo:"bar"," & @CRLF & _
" intervak:1," & @CRLF & _
" array:['test',"t\"est",'tet\'s']," & @CRLF & _
" 'test':"test te't test"" & @CRLF & _
"}"
Local $sSubst = "$1"$2""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)