import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\[|:|,)\\s*)'((?:\\\\'|[^'])*?[^\\\\])?'(?=\\s*(?:\\]|\\}|,))";
final String string = "{\n"
+ " aa:'a \\'a ab',test:\"ab\",foo:\"bar\",\n"
+ " intervak:1,\n"
+ " array:['test',\"t\\\"est\",'tet\\'s'],\n"
+ " 'test':\"test te't test\"\n"
+ "}";
final String subst = "$1\"$2\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}