import re
regex = re.compile(r"((?:\[|:|,)\s*)'((?:\\'|[^'])*?[^\\])?'(?=\s*(?:\]|}|,))")
test_str = ("{\n"
" aa:'a \\'a ab',test:\"ab\",foo:\"bar\",\n"
" intervak:1,\n"
" array:['test',\"t\\\"est\",'tet\\'s'],\n"
" 'test':\"test te't test\"\n"
"}")
subst = "$1\"$2\""
result = regex.sub(subst, test_str)
if result:
print(result)