using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\[|:|,)\s*)'((?:\\'|[^'])*?[^\\])?'(?=\s*(?:\]|}|,))";
string substitution = @"$1""$2""";
string input = @"{
aa:'a \'a ab',test:""ab"",foo:""bar"",
intervak:1,
array:['test',""t\""est"",'tet\'s'],
'test':""test te't test""
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}