# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(?:[[:alnum:]]+[[:blank:]]*)?[0-9]+]//g;t' <<< "[76][note 7] just like traditional Hinduism regards the Vedas "